Download the ECRI App

ECRI is compatible with:

Apple devices: iOS 9+

Android devices: 5+ 

Both Android and iOS require internet (cellular or WiFi), Bluetooth 4 and GPS.  If you're not sure, most phones sold during the last several years are compatible.

 

Download on Apple App Store Download for Android from Google Play
x
x